OpenOffice Reveals Motivation for Security Updates

Sep 09, 2009

Earlier than previously announced, the OpenOffice Project has released information regarding the newest security updates, spurred on due to gaps in security.

The software project team has advised users of the various release branches of versions 3 and 2 to update their software as soon as possible. More detailed information regarding these security loopholes were planned for September 11, but this info has been made public already.

The first security vulnerability (CVE-2009-0200 and CVE-2009-0201
concerns the processing of data in the format Windows meta-file (WMF). Manipulated data in graphic format could trigger heap overflows and under certain circumstances allow infiltrated code to execute under the authority of Office users. This issue was discovered by Dyon Balding from the company Secunia Research. This loophole also affects every version of Open Office 1.

The second loophole (CVE-2009-2414 and CVE-2009-2416 affects the processing of XML documents, including those in Open Document format (ODF). A targeted XML document could cause malicious code to execute.

Neither of the potential vulnerabilities have met with a real exploit of security to date. The most certain of solutions is to install either Open Office 3.1.1 or 2.4.3. which are the most current versions of the software.

Related content

comments powered by Disqus

News

njobs Europe
What:
Where:
Country:
Njobs Netherlands Njobs Deutschland Njobs United Kingdom Njobs Italia Njobs France Njobs Espana Njobs Poland
Njobs Austria Njobs Denmark Njobs Belgium Njobs Czech Republic Njobs Mexico Njobs India Njobs Colombia