Proprietary Driver for Ubuntu 9.04: Fglrx for X Server 1.6

Mar 18, 2009

By Canonical's Bryce Harrington's account, AMD has delivered an ATI driver that should be compatible with the X Server 1.6 found in, among other places, Ubuntu 9.04.

Users of ATI graphics cards are used to some grief. Added to the chaos that many coexisting drivers can cause, now comes the announcement that commercial driver support for some pretty recent graphics cards is available. Insight comes from Bryce Harrington in an Ubuntu mailing list. AMD/ATI is providing a commercial driver, the fglrx 6.800, that should work with X Server 1.6.

That's welcome news. Up to now, the buzz has been that Ubuntu Jaunty users would have 2D support on their ATI graphics cards only. According to Harrington, the new fglrx driver, which passed the XSmoke test, is a prerelease of a Catalyst 9.4 driver that should appear somewhere in the next two weeks. Harrington has packaged it in fglrx-installer 2:8.600-0ubuntu1. The downside is that the newest generation of the driver doesn't support any of the "older" ATI chipsets, which at this point include the R300 through R500 chipsets.

Harrington recommends using the open "ati" drivers for the older cards (where "ati" is a wrapper for the radeon and radeonhd drivers). The open source driver currently supports ATI cards from Radeon 7000 through Radeon HD 4870 with 2D and the R500 through R700 generations with rudimentary 3D support over DRI.

Comments

  • bolek

    <a href=" http://buytramadolonlinewithoutaprescription.com/ ">Buy Tramadol Without Prescription</a> <a href=" http://www.buytramadol.im/ ">Buy Tramadol</a> <a href=" http://yourpharmacy.us/tramadol.php ">Buy Tramado Without Prescription</a> <a href=" http://erbuynowtramadol.zoomblog.com/ ">Buy Tramadol Online</a> <a href=" http://vampirefreaks.com/BuyTramadolOnline ">Buy Tramadol</a> <a href=" http://eauptimum.com/ ">Buy Soma</a> <a href=" http://www.buysomaonline.im/ ">Buy Soma</a> <a href=" http://www.cengines.com/ ">Buy Tramadol</a> <a href=" http://buyonlinexanax.net/ ">Buy Xanax Online</a>
  • ATi Needs Ubuntu Drivers... NOW.

    Ok, so I have this little laptop that has done me well in the past on Windows and Ubuntu, and still continues to do just fine with Windows 7. However, Ubuntu has been living hell for me. When I attempt to install, I can use the GUI. I had to install through text. Not easy, it cost me my Windows installation - Twice.

    Now this was back in the days of 8.04. Ubuntu found the restricted drivers, installed them, and I was up and running... sort of. Lots of stuff didn´t work, but at least I had the drivers. Then 8.10 came along and it automatically got the new drivers. Nice. Then 9.04 came along. And I have yet to find a working driver for my X1270 (I think, it might be an X1170 though) so now I am stuck with crappy looking graphics, buggy system performance, and slow response times.

    GET YOUR ACT TOGETHER, ATi. WE NEED A BETTER SYSTEM FOR DRIVERS! MAKE IT AUTOMATED AND MAKE IT LOOK LIKE YOU ACTUALLY CARE ABOUT YOUR CUSTOMERS. I WILL NEVER AGAIN BUY AMD/ATi AND THIS IS MY REASON - YOU SUCK. GET IT TOGETHER.

    Thank you.
  • Bye bye AMD/ATI

    Frustrating, I have an X1400 in a laptop, and can't have 3D on jaunty... It seems nvidia and not ATI is getting my money from now on!
  • Cannot view any video

    I am also done with ati/amd. I will not purchase another product by them or any company that wishes to restrict users by the use proprietary manure. If something is 'proprietary' should it not also resonate with the ideal level of quality and competence that a company would want to associate with their name? Pathetic work by ati.
  • you're the greatest

    Yfrwlf cooooooool tip with your ati config code. I didn't belive as my pc restarted and worked.
  • ATI 4850 Kubuntu 9.04 --> barely-usable system


    I installed a new video card a couple of months ago, the the ATI 4850. Ever since, I have had an unstable system: long pauses in accepting input or updating the display, and the GUI crashes at least once per day, so that I have to log in from a different system and restart kdm. Sometimes that doesn't work, the system is dead.

    I chose ATI because I thought they were going open source with their drivers. Whatever the reason, I will not buy ATI equipment any more until I read about much better support for Linux.

    This video card is a disaster.
  • Lesson Learned

    AMD/ATI will NEVER have my business ever again.
  • ATI Sucks

    I worked for ATI several years.
    All development at ATI Markhamm, Canada is a mess, management sucks,
    everiting sucks. Their cards sucks as well, I ddid not get how AMD made a
    deal with these guys. They are not able to get a driver working. The mess
    has deep roots and cannot be removed.
  • ATI no support

    Also very unimpressed, have always bought ati equipment, swapped to linux, and realise that they dont support there customers at all, will never again.
  • No more ati

    FUCK ATI NO Fglrx driver in ubuntu 9 04 for the X1600 cards

    No more ati for me. GF only !!!
  • ATI should go open source

    Having upgraded my Lenovo Z61M to Ubuntu 9.04, I tried without success to get a decent video setup working. Either crashing if using ATI drivers or an extremely poor video output using open source drivers. And I am not talking fancy videos and zapping screens here. I'm talking about a working business environment.
    Dual monitor setup? - Haha, what a joke.
    Triple monitor? - What was I thinking?
    I thnk that drivers should be more easily accessible to the public, especially if a company is not willing/able to provide up-to-date software.
    Remember the outcry about Daniel_K (about a year ago), when he got jumped upon by Creative Labs? Over 2000 blog entries within a couple of days!
    See <a href="http://forums.creative.com/...ascending&page=1">
    It is simply ridiculous that my video card (ATI Mobile Radeon X1400) is considered a "legacy product" after 2 years.
    (How old is Windows XP?...)
    So - what choice do I have? I will return to Ubuntu 8.10 and wait. And wait. And probably join the fate of good old Pluto.
  • FUCKIN LOLOLOL BOYCOTT ATI

    FUCK ATI and NO no Fglrx driver in linux for the X300/600 cards

    No more ati for me.
  • add me to the list

    I just got a good deal on a computer with P4 3.0, 2 gigs ddr2 ram and a radeon x1950xtx. I threw 9.04 on there without looking and ended up getting burned. Now I can see why the guy was quick to sell the card.
    He found out Ati isn't going to provide a driver for Windows 7 either. That at least makes me feel better. I still wish I hadn't gotten this card. Anybody wanna trade for a Nvidia card? I really only need halfway decent 3D.
  • no big problems...

    I'm using ubuntu 9.04(jaunty) on a HP6735b laptop (AMD Puma) and exept for a few hickups it works fine...
    The most painfull one is that when fullscreen, video acceleration works fine(even full HD), but when windowed, not a chance...flash doesn't accelerate anything at all(this sux most)...

    On the other hand, everything(that I want) worked straight from the start, it's the main reason why I switched from OpenSuSE 11(no wifi support)...

    p.s. I completely aggree that if ATi can't do it right, they should let others at least try...
  • Turn back to the default dirver of ati card of ubuntu 9.04 after frozed by the proprietary driver .

    step1 Reboot;
    step2 Choose "Recovery Mode" at grub menu;
    step3 sudo apt-get autoremove xorg-driver-fglr, and choose "yes";
    step4 Reboot again; Choose "Recovery Mode",Choose "xfix ...";
    step5 After "xfix ..." Resume Normal Boot

    OK
  • my ATI 4870 X2 works now in Ubuntu 9.04

    I tried the "sudo aticonfig --initial" thing and everything works now, thank you. I can finally use the newer distros which use x-server 1.6.

    I don't know if you can install the driver from the restricted driver manager / repository and use the above command to fix it, but the default install does not work, either from the repository or from AMD's site.

    I downloaded the ati-driver-installer-9-6-x86.x86_64.run from their site and ran it using --buildpkg Ubuntu/9.04 (as it instructs you to do if you select the build package option instead of just straight installing it, that way you can easily remove the packages if it doesn't work later).

    Then after installing all the packages, and running "sudo aticonfig --initial", I was able to reboot and have a functional desktop.

    BTW, the stupid restarting X hotkey control-alt-backspace issue is resolved by installing the "dontzap" package and running "sudo dontzap -d".
  • 4870x2

    the 4870x2 works great with SuSe 11.1 but there is some problem with resolution ; it can't be adjusted.but my Ubuntu 9.4 garbles at startup with the proprietary driver, what a shame ATI, last time i drop 500 bucks on one of YOUR cards good look with future sells. Just had to get this off my chest new I7 board that I bought last year and all the goodies and I have spent days getting it to work right with SuSE 11.0 (barely) I really want to get away from SuSE and RH.
  • Ati's fault

    Ati sure are taking their time again.

    Good thing Update Manager (on 8.10) warned me that fglrx doesn't work with 9.04 before starting to install stuff! (Thank you, Canonical!)
  • @Aubs: Fedora's next release (rawhide) will have the same problem as Ubuntu 9.04.

    ,
    Most 2009 Linux distro's will use Xorg-server 1.6, and ATi's _newest_ generation of graphics cards don't have a full-featured driver compatible with these _new_ Linux distro's that use Xorg's latest software. ATi has had 3+ months since Xorg-server 1.6's release to make a driver that's compatible with most 2009 Linux distro's. I could understand if ATi stopped support of _old_ ATi cards for this year's latest Linux distro's, but this is ridiculous. Maybe next they'll promise support of Windows, without disclosing their newest cards only have drivers for Win98 and XP, no Windows 7 or Vista. No wonder they're nearly bankrupt; it's too bad since their hardware finally got competitive with Nvidia (which made me give them another chance after getting burned with a totally unstable All-in-Wonder card 8 years ago...) but ATi's hardware, despite being decent now, is worthless in Linux w/out good software (like 3D drivers).

    The versions of Fedora you mentioned are just older than Ubuntu 9.04, and therefore (thru Fedora 10) Fedora doesn't use v.1.6 of Xorg-server ...yet. Distrowatch.org says Fedora's next release will use Xorg-server 1.6.1, which is incompatible with ATi's driver (FGLRX). So, please RTFM (or read the article and related articles, as the case may be...) before bashing Ubuntu again, because you'll sound a lot less clueless if you open your eyes/ears BEFORE you open your mouth and falsely accuse Ubuntu/Cannonical of being the only one w/this problem and the cause of it.

    But, I will blame Ubuntu's team for 1 thing: FGLRX doesn't install for the countless people who replied above (and didn't work for me) as _simply_ as Cannonical's Harrington described in this March 18th article, and I do think Ubuntu is wrong to not warn people on their 'downloads' page and in Known Issues etc, that fglrx may take some extra steps (to make it stable in 9.04), because if Ubuntu made a warning that's conspicuous (to override Harrington's obviously-faulty March 18th proclamation that FGLRX now is stable just by downloading the latest version that Ubuntu's servers offer...), you wouldn't see so many angry replies above, you wouldn't have people waste time and bandwidth downloading the FGLRX package and then un-doing the damage it does to 9.04, and then the wasted time we all spend googling to see bug-reports for _why_ our FGLRX download killed the 9.04 Jaunty that we just freshly installed, and how to make FGLRX work with Xorg-server 1.6 and getting several different answers.

    I've seen many people saying FGLRX works if you input "sudo aticonfig --initial" (in terminal/konsole, after installing FGLRX but _before_ rebooting...), apparently it inserts a "DefaultDepth 24" under section "screen" of xorg.conf, and possibly inserts more into xorg.conf...but I haven't tried that yet. I just came across this webpage in google after my Jaunty installation got FUBAR'ed by ATi's driver 2 hours ago.
  • ATI video card support for Ubuntu

    Just a quick addition to my above message, there seems to be lots of anger directed at ATI for the problems Ubuntu has with its cards but other distros don't seem to have these kinds of problems with ATI. As I said above, I have Fedora 8 running quite happily on the machine that Ubuntu can't handle. If they can at least provide a way to see the screen why can't Ubuntu? Do Ubuntu actually test their releases before they are made? Can they at least say that there are issues with ATI before people waste their time downloading rubbish that won't work? If I was the boss of their release team I would be doing some severe arse kicking about now.
  • Ubunt 9.04 install problem with ATI HD3650 card

    I have just downloaded the Ubuntu 9.04 desktop ISO and tried to install it on a Athlon XP with a ATI HD3650 agp card. This machine in currently running Fedora 8 no problem. However Ubuntu stalls with a garbled black screen with a thin line of graphics/text at the top of the screen soon after selecting the language option. This happens both when trying the run from CD option and the install to hard disk option. Pathetic. This video card is hardly an orphan and other Fedora 6, 7, 8 and 10 quite happily render a readable screen, why can't Ubuntu? If this is supposed to be the premier Linux distro then its easy to see why Linux has such a small market penetration. Once again just pathetic, I have wasted 700mb of my broadband allowance for nothing. Just pathetic.
  • Bad work by ATI

    Like many other folks commenting on this post, I too discovered this a bit late, after I had upgraded my system to Jaunty. This attitude of ATI, however, simply reminds me to purchase an NVIDIA chipset next time for my system. Bad Boy, ATI!
  • stupid driver

    this does not work x server freaks out and the computer locks up and needs a hard reboot. make a new driver or forget getting any future buisness mad
  • 9.04 / hd 3650

    Hello,

    I'm sitting right in front of my brand new laptop trying to get the ati card working. All I need is some 3D acceleration for working with blender 3D. Hell - why didn't I look closer to the hardware, why didn't I buy Nvidia?

    My screen goes black when I start X. No keyboard input is accepted anymore.

    If I really learnt something during the last two days of trying around - never ever by a machine with ATI on board!! Since years I was using Linux on Nvidia systems without serious problems.

    By the way, currently my machine runs under Ubuntu's live session - the only way to get it work.
  • 9.04 4780x2

    Hello.

    I got my 4870x2 partially working. I had the same problems as most ppl had with a corrupt login screen. I deleted the fglrx package. Booted with the normal package and got a screen. Then I installed the fglrx package went through the aticonfig command and set up the card with that. Still having trouble with setting up xfire on a single screen so thats what Im working on now. Films flicker when being played but thats the xfire problem. Hope that helps a bit.
  • Same thing with my brand new ATI 4850 Card

    I wish I stayed with Ubuntu 8.10 until ATI get their crap together. For longest time I was using the Radeon X1900XT card and it was a fine card mind you. Just thought maybe I upgraded the card to ATI 4850 the native ATI drivers would work on the fly when I upgraded Ubuntu 8.10 to 9.04. Well, it didn't and it ticked me off.

    I had to use my laptop to google for answers to get my desktop back to at least some workable fashion. After some extensive digging and inputted the commands in CLI I was finally able to get my desktop back, not in hi-rez I wanted but it's still usable.

    Thanks alot ATI for putting folks like us in this mess. ATI makes awesome cards but their driver support isn't worth for two-shits for Linux folks. Last I heard Nivida makes decent Linux drivers, not perfect but it's workable solution.

    I hope they release 9.5 that we CAN use!!
  • Ubuntu 9.04 + 4870x2 R700 9.4 Drivers are no good

    As reported earlier Latest version of ATI drivers 9.4 shoing corrupted screen and stall of PC on login to x-server. Configuration of any kind is not helping. Also tried to compile my own drivers, still showing same thing. Here is video of error on Ubuntu 9.04+4870x2+9.4 drivers: http://www.youtube.com/watc...QS7_U&feature=channel_page

    I really tried to do anything possible and whatever I know ...nothing helped I think at this point this is something too new and totally not working. If anyone know how to fix it we are all ears...Thanks !
  • fuck AMD/ATI

    i'm using T60 with X1300 ATI . so i can't update to 9.04?
    without VGA driver, some compiz effect can't be good (dust line , can't have gaussian blur...)

    FUCK AMD-ATI
  • What?

    @ whoever said AMD stole from Intel.

    I am not amd fanboy and yes they have been crapping all over us lately. However that said wasn't it Intel came out with (low IPC/x64/integrated Nbridge/paralell processing idea AFTER AMD? Seems to me your backwards which makes you sound stupid.
  • lower resolution + open driver

    I was having the same issues people have been reporting with my 9.04 install and after much fiddling around I've tried to lower the resolution as a last resource before downgrading to 8.10, and to my surprise it worked.

    Granted it's not the 1920x1200 i'm used to, but at least i got the system working now without the need for me to move files around and reinstall 8.04, to upgrade to 8.10. Not sure if there's an easy path going backwards...

    My system is a Dell Inspiron 6000 laptop, with a Radeon x300

  • Shit...

    I installed Ubuntu 9.04 before I found this thread. Does not look like AMD is changing its mind, not the first time for ATI. Just frustrating!!!
  • Freeze X display

    Still here, no solution, and my only hope to see my desktop are the opensource drivers, but no 3D... well, can't complain about, but I wish to see more responsability on releasing a official proprietary driver without the expected quality. My specs just to see if theres any one through this too : Intel Q9550, ATI 4870X2, 4GB DDR3... It's a 6 month build system, it should work, but.... freeezeeee, no XxxXxxXxxx!!!! damm'int FLGRX!!!!
  • ATI/AMD has sucked through time

    At first they stole processor schemes from Intel, now they make bs hardware and drivers for them. Like 6-7 years ago I was fan of AMD, now I buy only Intels and Nvidia hardware, unfortunately I was given a MacBook Pro from my employer which has ATI videocard, no ubuntu 9.04 for me it seems.

    I hope that AMD changes its policies, or now supplier is continuing to sell AMD products.

    Till then, F*CK YOU ATI&AMD.
  • No ATI joy here, either

    My graphics card is a Radeon X800 (not sure what chipset it uses). Catalyst installed and functioned properly under Ubuntu 8.10 but under 9.04, after a few screen blackouts and reinstalls, I could only get a basic display, just the minimum desktop effects. Disappointing. I went back to 8.10 and hope that soon there'll be support for my graphics card.
  • ubuntu 9.04 fglrx crash on radeon 9600

    Supposedly the new driver isn't out yet, but I find the radeon 9600 won't fire up after loading fglrx driver. The original upgrade worked but with only 2d graphics. This is on an older but not ancient desktop (single-core athlon x2500, 32 bit, 2.5 GB RAM)
  • that's the last time I buy a machine with an ATI graphics

    Thought I was getting a bargain on this end-of-line reduced Thinkpad T60. Since then I've wished numerous times I'd read more about the graphics cards and gone with NVidia, which have always been great for me in the past. Won't be making this mistake again.
  • AMD/ATI

    I've got a Intel C2D, 2gig with an ATI X300 PCI-E video. There wasn't no support for 3D on Ubuntu 9.04 with the open source drivers, it didn't recognize my screen as it is... using with 1024x768 sucks.
    Tryied to install the -radeon driver and it didn't work.. instead, my computer stopped working, it didn't even start again, used to crash every time on X startup. At the end, I lost all my files and lost every single file that was in that computer. I hope ATI take some providence, as soon as possible.
  • Ubuntu 9.04 and AMD/ATI Radeon HD2*00 - no go so far...

    Upgraded, then completely reinstalled Ubuntu to 9.04 (Intrepid), on a 2.9 Gig Celeron with 2 Gig of RAM with a Radeon HD2600XT AGP card, on a HDTV using HDMI, at 1360 x 768 with 512Meg VRAM.

    What I am getting as a fault is no panels, and apparently the screen size is larger than the monitor - BUT - rearranging the icons keeps them to the screen size displayed. strange.

    The native drivers and the AMD/ATI 9.4 drivers don't work now. Details here on Ubuntu forums:
    http://ubuntuforums.org/showthread.php?t=1133931
  • ATI/AMD One Long Sad History of Dropping the Ball

    I'm sitting here on my Lenovo T60 laptop with an ATI Radeon X1300 card. I've got a Core 2 Duo processor, 4GB of RAM, 320GB HD, etc. etc... I'm not on some slow, old piece of hardware. In fact, I would hazard a guess that I am using one of the most popular laptops sold in the past few years. And, all I want to do is use the most popular version of Desktop Linux in the world with reasonable graphics capabilities. Instead, ATI/AMD continue their horrific support for their own hardware as they have for the past 3 years. I will do anything in my power to avoid ever using ATI hardware on any platform I own again. If ATI cannot write closed, proprietary binary drivers for their own hardware, then for crying out loud, let the Open Source community do it right and open source you stupid drivers. Great - you have a new driver, and it drops support for, literally, hundreds of thousands of users (or more) world-wide. This is not impressive, this is simply painful for me, embarrassing for you, and continues your horrible support trend of your own hardware for the past 3 years. Best of luck not going out of business.
  • More ways to mess up an install

    I upgraded to 904 yesterday and found the missing support for Radeon X600 too. Then I tried to run aticonfig and it suggested a package which I did. Before I could at least get 1024 X 768, but now X starts with jibberish on the screen and it is hard reboot time.
    Very disappointing indeed. - don't try it.
  • NO support fot ati x1xxx

    Of course you can't install ati drivers because ati dropped from supoprt all graphics using chipset 500 and older(all x1xxx cards) and new ubuntu 9.4 supports xserver1.6 which ins't compatibile with ati drivers 9.3 and older.
    if you have ati x1xxx don't install ubuntu 9.4 !!!
  • Proprietary Driver for Ubuntu 9.04: Fglrx for X Server 1.6

    After upgrading to Ubuntu 9.04 I've found that there is no Fglrx driver for ATI X600 card.
    The open source driver is only good to play a tux racer, very sluggish performance.
    I've tried to install the latest ati-driver-installer-9-3-x86.x86_64.run from ATI web site but it gives an error: "Error: ./default_policy.sh does not support version default:v2:i686:lib::none:2.6.28-11-generic;"
    I've installed then Fglrx through package manager but it made computer freeze.
    I found funny that recovery mode has option to fix video related problems which was useless in my case.
    I've tied to reconfigure xserver: dpkg-reconfigure -phigh xserver-xorg without success.
    Eventually I had to remove Fglrx driver.

    My opinion is: dont't upgrade to Ubuntu 9.04 if you have ATI video card
  • Freeze

    This freezes my computer on X start and I need to use MagicSysRq to restart the computer. I have a laptop Radeon Xpress 1250.
  • Freezes my X

    I have a 4870X2 card and Kubuntu 9.04 beta installed, I've tried several times to update to 8.60 through a vast imagine ways and nothings seens to work, when it reaches X the server shows graphics corruption and the PC freezes.....
  • causes computer to freeze

    This causes the computer to hang upon initialization of the X server. I'm using a laptop with the Puma platform, so ATI HD3400 and HD3600.
  • Radeon Xpress 1250

    The fglrx 8.600 driver caused my computer (with radeon xpress 1250) to crash at login until I removed it by command prompt.
    The other drivers are really slow!
  • Support Radeon Xpress 1250

    8.600 - aticonfig reported: no supported adapters!!!!!
    Samsung R18 Video Radeon Xpress 1250
comments powered by Disqus

Issue 166/2014

Buy this issue as a PDF

Digital Issue: Price $9.99
(incl. VAT)

News

njobs Europe
What:
Where:
Country:
Njobs Netherlands Njobs Deutschland Njobs United Kingdom Njobs Italia Njobs France Njobs Espana Njobs Poland
Njobs Austria Njobs Denmark Njobs Belgium Njobs Czech Republic Njobs Mexico Njobs India Njobs Colombia