Vodafone Releases GPL Driver for UMTS/GPRS Cards

Oct 10, 2007

Mobile communications provider Vodafone has just released version 1.0 of its Mobile Connect Card Driver for Linux. The driver supports the use of GPRS, UMTS and HSDPA, as well as SMS transmissions.

At present, the driver supports the Option GlobeTrotter 3G+ EMEA (PCMCIA), Huawei E220 (USB) and Huawei E620 (PCMCIA) cards. According to the manufacturer, Linux power users should have no trouble modifying the driver to support other cards. The installation guide has more details. Vodafone is already working on version 2.

The card drivers GUI-based configuration and user interface accepts the PIN and displays connection information. It also serves as an SMS program and address book.

Vodafone offers the Mobile Connect Card Driver for Linux for UMTS and GPRS cards.

The driver requires HAL and Python as well as a couple of network and GUI libraries. The Huawei PCMCIA card also requires kernel version 2.6.18.4. The project page on Vodafone's developer portal includes ready made packages for Fedora 7, Ubuntu Feisty Fawn and Suse Linux Enterprise Desktop 10.1, as well as the source code, which is available under GPLv2.

Related content

  • G2: This Time on Vodafone

    A presentation at the Mobile World Congress in Barcelona revealed that HTC and Vodafone are releasing a G2 phone (a.k.a. HTC Magic) as the successor to HTC and T-Mobile's G1 Android phone. Vodafone claims "exclusive deal" for G2. Where goeth the G3?

  • Bluetooth with GPRS

    If your mobile phone contract includes GPRS mobile Internet service,
    you can use a Bluetooth phone as a wireless modem for your Linux
    portable computer.

  • Ask Klaus!

    Klaus Knopper is the creator of Knoppix and co-founder of LinuxTag expo. He currently works as a teacher, programmer, and consultant. If you have a configuration problem, or if you just want to learn more about how Linux works, send your questions to: klaus@linux-magazine.com

  • GPRS in Linux

    Permanent mobile Internet access might sound like a nightmare for some, but for others it is a dream come true. All you need is Linux and a fairly recent mobile phone.

  • AMD Provides Legacy Driver for Old ATI Cards

    Contrary to original plans to support the older ATI cards, AMD now wants to provide a legacy driver for them, along the lines of Nvidia.

comments powered by Disqus

Issue 178/2015

Buy this issue as a PDF

Digital Issue: Price $9.99
(incl. VAT)

News

njobs Europe
What:
Where:
Country:
Njobs Netherlands Njobs Deutschland Njobs United Kingdom Njobs Italia Njobs France Njobs Espana Njobs Poland
Njobs Austria Njobs Denmark Njobs Belgium Njobs Czech Republic Njobs Mexico Njobs India Njobs Colombia