Adobe Gives New Life to NPAPI Plugin for Linux

Sep 07, 2016

Adobe won’t kill the plugin in 2017

Adobe is breathing new life into its Flash Player plugin for Linux. The company has released a new version of its NPAPI plugin for Linux, bumping the version number from NPAPI 11.2 to 23, bringing the Linux version of the NPAPI plugin in sync with the current version in the latest branch.

Linux has two versions of Flash Player: NPAPI and PPAPI. PPAPI is used by Chrome and Chromium web browsers and is fully maintained. Although Adobe stopped working on the NPAPI plugin for Linux, with end of life scheduled for 2017, with the new release, NPAPI gets a life extension.

Adobe said in its blog post that this change in plans is a security initiative for those Linux users who still need the plugin, but it will not get many of the features found in the PPAPI plugin.

Users who are looking for GPU 3D acceleration and playback of DRM’d videos must use the PPAPI plugin. Adobe said in a blog post, “If you require this functionality, we recommend that you use the PPAPI version of Flash Player.That said, we believe that the new NPAPI build represents a significant step forward in functionality, stability, and security and look forward to hearing your feedback.”

Despite this lease on life, Adobe Flash is on its way out. Major browsers have already started blocking Flash content by default.

Related content

comments powered by Disqus

Issue 30: Getting Started with Linux/Special Editions

Buy this issue as a PDF

Digital Issue: Price $15.99
(incl. VAT)

News

njobs Europe
What:
Where:
Country:
Njobs Netherlands Njobs Deutschland Njobs United Kingdom Njobs Italia Njobs France Njobs Espana Njobs Poland
Njobs Austria Njobs Denmark Njobs Belgium Njobs Czech Republic Njobs Mexico Njobs India Njobs Colombia