Klaus Knopper answers your Linux questions

Ask Klaus

Article from Issue 175/2015

Changing default applications, switching BIOS settings for newer distros, running an old Windows application in VirtualBox with a security dongle, and Live distro security with an overlay file.

Wrong Editor

Dear Professor Klaus Knopper: I am currently using the Xubuntu 14.10 operating system on my desktop at home. It is the AMD 64 architecture version. I have two user accounts on my OS: Administrator and Desktop User.

The problem that I have with my OS is that whenever I double-click on a plain/text file within the Administrator or Desktop User account, it always opens it with AbiWord rather than Mousepad. Can you explain why it does that in those accounts, with a plain/text file, when the default application to open it with is set to Mousepad and not to AbiWord?

Yours sincerely, Miss S Fox

The file manager in Xubuntu decides on the type of a document based on the file name suffix, rather than the file's content. If your text file is named file.doc, the file manager will start AbiWord regardless of whether the file is really just a text file. If the file has no suffix, the file manager uses a different approach and may find the correct program for handling the files content from the mime type detected by the file command.

The default application started when you click on a document in Xubuntu's file manager can be changed in different ways, as you already mentioned in your question (Figure 1). The quickest method should be clicking on the document in question, with the right ("menu") mouse button to open the context menu. There, select Open with other application, then select your favorite text editor program and check "use as default for this kind of file" before clicking OK (Figure 2).

Figure 1: Choose an application.
Figure 2: Set as default.

This procedure changes a line in the file $HOME/.local/share/applications/mimeapps.list file, which will look like this:


You can load this configuration file into a plaintext editor and look for undesired file type vs. application settings, and then correct them manually.

Another explanation why AbiWord opens the file when the default application is correctly set to a plaintext editor like Mousepad could be a modified mousepad.desktop file that changes the path of the application. Check your $HOME/.local/share/applications directory for modified .desktop files. The line beginning with Exec= defines the program actually started when the .desktop file is used.

UEFI Issues

Dear Mr. Knopper: I was just reading your answer to a question in Linux Magazine 3/2015 (English edition). On page 54, "Carlos" writes:

"Although I have been able to install and use Ubuntu 14.04 successfully on both my laptops by downloading the image from ubuntu.com (I even tried Mint 17 on one of them, but did not like the interface, so switched back to Ubuntu), … ."

In your answer, you then write that UEFI Secure Boot is probably to blame for the fact that he does not reach the boot menu of Ubuntu 14.10.

This does not make much sense to me, if you remember the entry sentence:

"Although I have been able to install and use Ubuntu 14.04 successfully on both my laptops by downloading the image … ."

How did he get the other distros to run? Or am I missing something?

Greetings, Martin Knappe

Understandable. I'll explain. :-) I assumed he tried several settings (which may include UEFI, in which case the "secure boot" option should be disabled). However, it could also happen that a newer version of the DVD's bootloader features a new UEFI loader that is first detected successfully by the computer's firmware, yet cannot boot because of a missing signature, with no auto-fallback to the legacy boot methods. So, Ubuntu adding UEFI capabilities to the boot medium actually may have made things worse, and the computer does not detect the medium as bootable anymore. In this case, making sure that the BIOS has UEFI completely disabled could help.

The other distros may have booted successfully simply because they did not support UEFI and were booted by the standard El Torito method, whereas the newer Ubuntu version has some kind of UEFI support that is confusing the BIOS and just fails.

I hope it's more clear now why I recommended switching BIOS settings that may have worked in older distros and thus seemed unrelated to UEFI. Sometimes, hybrid bootloaders that try to "intelligently" autoswitch to a certain boot method actually make things worse. My general hint of disabling UEFI in the BIOS (and also "Secure Boot") is the one that usually works best even with hybrid (UEFI/non-UEFI) bootable media in the case of boot problems.

Backward Compatibility

Hi Klaus, I'm using your Knoppix 7.3 Live DVD for all my banking and other secure transactions. That must be really safe as it's not possible to write to a read-only DVD, so it's not able to catch a virus. I'd imagine that Live boot from a Live flash stick would be slightly less safe?

My main question: I have a problem with backwards compatibility. Let me explain, I have an expensive but old Windows application that runs on 3.1 up to XP. The best choice would be to run it on Win98 in VirtualBox under Linux. In fact, it does run as far as the dongle on the parallel port, then it's not able to bit-twiddle the security dongle. My laptop does not have a parallel port.

My next try was to put Win98 on my more modern desktop, which failed with the message that I was out of memory and I should remove some stuff from config.sys and autoexec.bat. My next stab was to install the old 6GB Win98 hard drive on the modern machine and boot up Win98. It again reported insufficient memory to initialize Windows and suggested removing some programs from the autoexec.bat and config.sys files.

For now, I'll have to admit defeat and keep my old Win98 machine with 256MB of RAM so as to run the old application should I need it again. I guess the low-level working in the BIOS and boot have changed a lot over the past 10 years or so, but I'd be interested in knowing what was changed?

Also you helped me with a video card problem (Linux Magazine, November 2013). Well, my AMD card died, so I put the video card on a slightly less old Intel system, and I no longer need the vga=771 boot option to run Knoppix or Mint 15. Strange stuff.

Regards, Ian

About booting from USB flash disk: Of course, it is potentially more secure to run from a physically read-only medium. The main filesystem part of Knoppix is a read-only ISO  9660 filesystem that does not support write operations without an overlay file or partition, and you can disable using the overlay with the knoppix noimage boot option. However, if you start software or a script that modifies the partition containing Knoppix, an attacker could install something else. An SD card with no overlay partition or file and a physical switch for disabling write operations could be a replacement for the read-only DVD and would boot about five times quicker.

About your Windows problem: The traditional BIOS routines have not changed much, even in modern computers, except for UEFI of course, so a newer BIOS is probably not the reason for memory- or port-related failures.

The "out of memory" message can simply be a misinterpretation of Windows caused by more memory available than the "memory driver" knows how to address. Removing (!) RAM, to get down to less than 2GB, or even less than 1GB, might help.

The old Windows software should run in Wine, in theory, but if it needs a parallel port dongle as an ancient copy protection method, you are probably stuck with an old PC that still has this physical port. Emulation in a virtualizer could only help if you find a way to use a USB-to-parallel port adapter and simulate a regular parallel port to the guest OS.

Nice to know that the graphics card now works in your computer without needing the VESA framebuffer (vesa=) options. Sometimes, a different memory or I/O address configuration fixes problems that previously had to be circumvented by boot options or software changes.

Klaus Knopper

Klaus Knopper is an engineer, creator of Knoppix, and co-founder of LinuxTag expo. He works as a regular professor at the University of Applied Sciences, Kaiserslautern, Germany. If you have a configuration problem, or if you just want to learn more about how Linux works, send your questions to: klaus@linux-magazine.com

Buy this article as PDF

Express-Checkout as PDF
Price $2.95
(incl. VAT)

Buy Linux Magazine

Get it on Google Play

US / Canada

Get it on Google Play

UK / Australia

Related content

comments powered by Disqus
Subscribe to our Linux Newsletters
Find Linux and Open Source Jobs
Subscribe to our ADMIN Newsletters

Support Our Work

Linux Magazine content is made possible with support from readers like you. Please consider contributing when you’ve found an article to be beneficial.

Learn More