Ask Klaus!

Ask Klaus!

Article from Issue 102/2009

Getting Online


I'm sorry this is going to be a bit long-winded. You are my last resort before giving up on Linux, waiting for Haiku to come out, and praying that it will do the job.

I have: Elite group GS7610 ultra motherboard, AMD Athlon 3,000MHz CPU, 2GB RAM, and the SIS190 LAN connected to a BT Home Hub, which I cannot change right now. This is a dual-boot Windows XP and Fedora 8 system (if I can solve this problem, I'd love to upgrade to Fedora 10). There is a second PC on the home hub, too.

My problem is that I cannot get onto the Internet fully and cannot find any advice about my problem on the Internet using XP either. Firefox will start up but will not access any websites. It will go to Google, and I can even access my email from Google Mail. But when I do a search and then click on a website or enter a web address, Firefox and all the other web browsers I've tried just hang with the message "waiting for ?… ."

I've previously tried installing Ubuntu, but that collapsed when it tried and failed to get to for updates. Debian didn't even find my hard drive. Sabayon had the same issue as Fedora. SUSE would not access the web at all, even though I read that it was a breeze to install and get going. Mandriva took over my PC in the same way Windows does, and I hate that.

I've tried entering the IP addresses by hand and changing various settings as instructed by readers of another magazine, also switching off IPv6 settings and a host of other advice which I've now forgotten.

I'm not a programmer, just a user, and all my favorite software is on Linux, but I can't carry on trying to get updates to it all by using XP and transferring the new programs by USB drive.

Don't get me wrong, if I can get one distro up and running fully, I'd get rid of XP in a flash, but until then I'm stuck with it. Please can you help?


The good news is that you are already through the basic network configurations, in that you can retrieve and send email directly or from a web mail server, and your Internet access is working fine, except for one small but unpleasant detail.

The Internet is organized in addresses (IP addresses, at least one for each computer) and network ports, each one representing a service that you can access. For example, WWW is port 80; encrypted WWW is port 443. Apparently, your setup has already managed to get a temporary IP address for your computer as soon as you connect and at least SOME of the destination address/port combinations can be reached directly. Good!

Also, name resolving seems to work (i.e., the computer can find the IP addresses you want to connect to when you type a computer name). Otherwise, the error message would say "cannot resolve hostname" very quickly instead of just dying after awhile.

So, what's missing? The most probable reason (I cannot think of many others except for complicated VPN settings) is that the Internet provider allows DIRECT access only to selected IP addresses and all others are filtered. The reason for this inconvenient behavior might be that the provider has a "whitelist" of Internet addresses that can be contacted directly, and all the rest can be accessed only through a so-called "proxy."

A proxy is a computer on the Internet that runs a service for connection control and web page caching, somewhat speeding up access to web pages and allowing the provider to forbid access to unacceptable content (the provider could be forced by law to fully control web access and have a protocol of everything users try to access in their browser).

Without getting into a political discussion, the technical solution for getting access to websites is just to add the proxy address and port into the Firefox settings, which will give you access to the web via the provider's proxy and also let you exclude sites like Google Mail (which apparently is on the providers whitelist and can be accessed without the proxy).

By the way, you might find the correct proxy address in Internet Explorer's settings. Windows users have reported to me that this setting is located under Tools | Internet Options | LAN settings, and the information there can be entered into the Firefox Settings | Connecting to the Internet setup box.

About various distributions and various levels of hardware support: This story is never-ending. Debian tends to provide well-tested but not very new kernels in its "stable" branch; therefore, SATA hard disk controllers might not be supported out of the box, unless you compile a new kernel on your own. Other distributions can fail because experimental kernels and drivers are too new. I always have to find a good compromise between stability and good hardware support for Knoppix as well.

In theory, any distribution with a recent kernel should support your modem, but the user initiating the dial-out should be in Unix group netdev if you are using network-manager – which is now the default network setup tool in many distributions – to get access to the modem device.



I am new to Linux and have just installed SUSE version 11.1 on my Windows XP laptop in a dual-boot setup; however, I am unable to access the CD-ROM drive. Do I need to start an xterm and alter a bit of code, or is there a way to mount the CD drive? I know some commands in Linux (i.e., grep, dev, xfers hal, hda 1, etc.). Any help is appreciated.


It might be a permission problem, or just a missing entry in the disk drive configuration file /etc/fstab. Mine looks like the output shown in Listing 1.

Listing 1



This output reveals that the Linux device drive is /dev/hdc (the first master drive on the second IDE controller), its content appears at /media/cdrom0 after being mounted, UDF or ISO filesystems are autodetected, and, most important, ANY user (user) is able to mount it, it is just not mounted automatically at boot time (noauto).

With an /etc/fstab entry like this, your file manager (or you, in a shell), can just issue a mount /media/cdrom0 to access the CD-ROM's content at directory /media/cdrom0. If the user is in group plugdev (check with id), the command pmount /dev/hdc will mount the CD under /media/hdc independently from an /etc/fstab entry, provided pmount is installed.

Error Message


Thanks for all your help in the past. My system is partitioned to Ubuntu (GRUB) Fedora, SUSE, and XP. All was OK the previous evening with a normal shutdown, then SUSE had a kernel upgrade, so I had to go into Ubuntu to edit the menu, except I couldn't get into Ubuntu because of the following error message:

Users $HOME/.dmrd file is being ignored. This prevents the default session and language from being saved. File should be owned by user and have 644 permissions. Users $HOME directory must be owned by user and not writable by others.

I couldn't log in to SUSE in Recovery mode (or whatever it's called) because it wouldn't accept my password. I had a cloned disk for backup so I'm OK, but what happened?


The most probable reason (check with ls -ld /home/your_login_name) is that your home directory or files and directories therein do not belong to you anymore. This tends to happen when programs are started as root with graphical sudo programs like gtksu: They try to "fix" insecure permissions because they detect themselves running as root, but being controlled by configuration files belonging to "another user"; therefore, the home directory gets disowned accidentally.

Quick fix: Log in as root in text mode (linux 2 at the boot manager, enter root and root password), then enter:

chown -R your_login_name /home/your_login_name

If /home/your_login_name is a symlink to the real directory in your distribution, use

chown -R your_login_name /home/your_login_name/

instead, with no space before the final slash.

The files in /home/your_login_name should now belong to the correct user again. You might want to find out which program that was called as root in the graphical environment caused the problem, just to avoid this problem happening again at an inconvenient time.

Buy this article as PDF

Express-Checkout as PDF
Price $2.95
(incl. VAT)

Buy Linux Magazine

Get it on Google Play

US / Canada

Get it on Google Play

UK / Australia

Related content

  • Ask Klaus

    Klaus Knopper answers your Linux questions.

  • Ask_Klaus!

    Klaus Knopper is the creator of Knoppix and co-founder of the LinuxTag expo. He currently works as a teacher, programmer, and consultant. If you have a configuration problem, or if you just want to learn more about how Linux works, send your questions to: klaus@linux-magazine. com

  • Knoppix 7.3

    Knoppix 7.3 comprises the current state of Debian GNU/Linux development and comes with the current hardware support of kernel 3.13, a new update function, and extended security and privacy features.

  • Ask Klaus!

    Klaus Knopper is the creator of Knoppix and co-founder of the LinuxTag expo. He currently works as a teacher, programmer, and consultant. If you have a configuration problem, or if you just want to learn more about how Linux works, send your questions to:

comments powered by Disqus
Subscribe to our Linux Newsletters
Find Linux and Open Source Jobs
Subscribe to our ADMIN Newsletters

Support Our Work

Linux Magazine content is made possible with support from readers like you. Please consider contributing when you’ve found an article to be beneficial.

Learn More